close
دانلود فیلم
Virtual Switching System چیست

مروری بر VSS

سیسکو برای ساده کردن مدیریت و تنظیمات شبکه های سوییچینگ Virtual Switching System را ایجاد کرده است. بوسیله این تکنولوژی دو سوییچ سیسکو از سری 6500 را میتوان از طریق پورت های 10G بصورت یک STACK و یک سوییچ واحد تنظیم و در شبکه قرار داد. یکی از مزیتهای ایجاد یک سوییچ مجازی که حاصل دو شاسی 6500 است، مدیریت یک دستگاه و کاهش در تعداد Adjacency در شبکه است (از آنجا که بجای دو دستگاه Core، ادوات شبکه یک Core واحد را میبینند در زمینه مدیریت و همچنین از لحاظ پروتکل های شبکه و طراحی آن کار ساده تر میشود.)



مسلما از دیگر مزیتهای ایجاد یک سوییچ مجازی، افزونگی (Redundancy) و Load Balancing با استفاده از Port Channel است. در طراحی های قبلی شبکه ایجاد Ether Channel به خاطر ارتباط یک سوییچ لایه Access به دو سوییچ لایه Core مجاز و مهیا نبود اما از آنجا که در این توپولوژی سوییچ Access در واقع به یک سوییچ Core بواسطه دو لینک متصل است، این کار بسادگی قابل اجراست.

نقش سوییچ در VSS

  • VSS Active: سوییچ اصلی در VSS را بعنوان Active میشناسیم. کار این سوییچ مدیریت VSS است. این سوییچ Control Plane سوییچ VSS است و نقش مدیریت و اجرای پروتکل های لایه دو و سه را بعهده دارد. حتی مدیریت برق، کارت ها، کنسول و Management Plane بعهده این سوییچ است.
  • VSS Standby: وظیفه سوییچ Standby چک کردن وضعیت VSS Active است تا در زمان نیاز در نقش Active ظاهر شود. اما در عین حال همیشه مشغول Forward کردن ترافیک شبکه است و تنها ترافیک کنترلی را به Active ارجاع میکند.

Virtual Switch Link

به لینک بین دو سوییچ که منجر به ایجاد VSS میشود، VSL میگوییم. این لینک ترافیک Data و ترافیک کنترلی شبکه را بین دو شاسی رد و بدل میکند. VSL خود یک Port Channel است که بین پورت های 10G ایجاد میشود و بصورت Virtual Switch Link تنظیم میگردد. مسلما Control Traffic با اولویت بالاتری در این لینک رد و بدل میشود.

آماده سازی

برای تنظیم VSS نیاز به Supervisor Card مخصوص دارید. علاوه بر آن نیاز به Line Card ها و IOS که از VSS پشتیبانی کند وجود دارد. برای تست کردن کارتهای دستگاه و تطبیق سازگاری آنها میتوان از دستور زیر کمک گرفت:

6500A#switch convert check vss-capable
This is a VSS capable switch.
VSL ports can be configured in slot: 4, 5, 6

VSS Configuration

سوییچ های 6500 بصورت پیش فرض بعنوان سوییچ های Stand-alone یا منفرد عمل میکنند پس باید آنها برای VSS توسط چند قدم زیر تنظیم کرد:

Step1: از اجرای NSF و SSO که روش های Redundancy بین Supervisor ها هستند مطمئن شوید. برای اطلاعات بیشتر در این زمنیه میتوانید به پست مرتبط با Supervisor رجوع کنید.

Step2: شماره Domain و Virtual Switch را تنظیم کنید.

Step3: روی هر شاسی Port Channel با شماره مختص به خود را تنظیم کنید.

Step4: شاسی را از حالت Stand-alone به مد Virtual Switch تبدیل کنید.

Virtual Switching System چیست

Step1:

6500A(config)#redundancy
6500A(config-red)#mode sso
!

Step2:

6500A(config)#switch virtual domain ?
< 1-255> Virtual switch domain number

6500A(config)#switch virtual domain 100
Domain ID 100 config will take effect only
after the exec command ‘switch convert mode virtual’ is issued

6500A(config-vs-domain)#switch 1
6500A(config-vs-domain)#exit

6500B(config)#switch virtual domain 100
Domain ID 100 config will take effect only
after the exec command ‘switch convert mode virtual’ is issued

6500B(config-vs-domain)#switch 2
6500B(config-vs-domain)#exit

Step3:

6500A(config)#int port-channel 100
6500A(config-if)#
switch virtual link 1
6500A(config-if)#no shutdown
6500A(config-if)#exit
6500A(config)#int te5/4
6500A(config-if)#channel-group 100 mode on
6500A(config-if)#no shutdown
6500A(config)#int te6/4
6500A(config-if)#channel-group 100 mode on
6500A(config-if)#no shutdown

6500B(config)#int port-channel 200
6500B(config-if)#switch virtual link 2
6500B(config-if)#no shutdown
6500B(config-if)#exit
6500B(config)#int te5/4
6500B(config-if)#channel-group 200 mode on
6500B(config-if)#no shutdown
6500B(config)#int te6/4
6500B(config-if)#channel-group 200 mode on
6500B(config-if)#no shutdown

Step4:

6500A#switch convert ?
check check if this switch and its modules are VSS capable or not
mode mode keyword virtual or standalone

6500A#switch convert mode ?
stand-alone stand-alone switch
virtual virtual switch

6500A#switch convert mode virtual

This command will convert all interface names
to naming convention “interface-type switch-number/slot/port”,
save the running config to startup-config and
reload the switch.

NOTE: Make sure to configure one or more dual-active detection methods
once the conversion is complete and the switches have come up in VSS mode.

Do you want to proceed? [yes/no]: yes
Converting interface names
Building configuration…
Saving converted configuration to bootflash: …
Destination filename [startup-config.converted_vs-20110705-214318]?

*** — SHUTDOWN NOW —

از تطبیق PFC mode بین دو سوییچ مطمئن شوید تا در زمان نیاز SSO بتواند بدرستی عمل کند:

6500A#show platform hardware pfc mode
PFC operating mode : PFC3C

حال پس از Reboot تنظیمات سوییچ را بررسی میکنید (دو سوییچ بصورت واحد در یک configuration روی سوییچ active دیده میشوند.)

6500A#sh run

!
hostname 6500A
!
switch virtual domain 100
switch mode virtual
!
mls netflow interface
mls cef error action reset
!
spanning-tree mode pvst
spanning-tree extend system-id
diagnostic bootup level minimal
!
redundancy
main-cpu
auto-sync running-config
mode sso
!
vlan internal allocation policy ascending
vlan access-log ratelimit 2000
!
!
interface Port-channel100
no switchport
no ip address
switch virtual link 1
mls qos trust cos
no mls qos channel-consistency
!
interface Port-channel200
no switchport
no ip address
switch virtual link 2
mls qos trust cos
no mls qos channel-consistency
!
interface GigabitEthernet1/1/1
no switchport
no ip address
shutdown
!
interface GigabitEthernet1/1/2
no switchport
no ip address
shutdown


interface TenGigabitEthernet1/5/4
no switchport
no ip address
mls qos trust cos
channel-group 100 mode on


interface TenGigabitEthernet1/6/4
no switchport
no ip address
mls qos trust cos
channel-group 100 mode on


interface TenGigabitEthernet2/5/4
no switchport
no ip address
mls qos trust cos
channel-group 200 mode on


interface TenGigabitEthernet2/6/4
no switchport
no ip address
mls qos trust cos
channel-group 200 mode on


interface Vlan1
no ip address
shutdown
!
ip classless
ip forward-protocol nd
!
control-plane
!
line con 0
line vty 0 4
login
!
mac-address-table aging-time 480
no event manager policy Mandatory.go_switchbus.tcl type system
!
module provision switch 1
slot 1 slot-type 147 port-type 61 number 48 virtual-slot 17
slot 3 slot-type 152 port-type 31 number 48 virtual-slot 19
slot 4 slot-type 227 port-type 60 number 8 virtual-slot 20
slot 5 slot-type 254 port-type 31 number 2 port-type 61 number 1 port-type 60 number 2 virtual-slot 21
slot 6 slot-type 254 port-type 31 number 2 port-type 61 number 1 port-type 60 number 2 virtual-slot 22
!
module provision switch 2
slot 1 slot-type 147 port-type 61 number 48 virtual-slot 33
slot 3 slot-type 152 port-type 31 number 48 virtual-slot 35
slot 4 slot-type 227 port-type 60 number 8 virtual-slot 36
slot 5 slot-type 254 port-type 31 number 2 port-type 61 number 1 port-type 60 number 2 virtual-slot 37
slot 6 slot-type 254 port-type 31 number 2 port-type 61 number 1 port-type 60 number 2 virtual-slot 38
!
end

Verification

همیشه به دوستانی که برای CCIE آماده میشوند گفته ام که verification یا تست عملکرد مهمترین مرحله در حین تنظیم یک سیستم است. (VSS و این مطلب ارتباطی با آزمون CCIE ندارد!) با دستورات زیر از عملکرد صحیح دستگاه مطمئن شوید:

6500A#show switch virtual
Switch mode : Virtual Switch
Virtual switch domain number : 100
Local switch number : 1
Local switch operational role: Virtual Switch Active
Peer switch number : 2
Peer switch operational role : Virtual Switch Standby

6500A#show switch virtual role

Switch Switch Status Preempt Priority Role Session ID
Number Oper(Conf) Oper(Conf) Local Remote
——————————————————————
LOCAL 1 UP FALSE(N ) 100(100) ACTIVE 0 0
REMOTE 2 UP FALSE(N ) 100(100) STANDBY 4004 1462

In dual-active recovery mode: No

6500A#show switch virtual link
VSL Status : UP
VSL Uptime : 43 minutes
VSL SCP Ping : Pass
VSL ICC Ping : Pass
VSL Control Link : Te1/5/4

6500A#show switch virtual link port-channel
Flags: D – down P – bundled in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
U – in use N – not in use, no aggregation
f – failed to allocate aggregator

M – not in use, no aggregation due to minimum links not met
m – not in use, port not aggregated due to minimum links not met
u – unsuitable for bundling
d – default port

w – waiting to be aggregated

Group Port-channel Protocol Ports
——+————-+———–+——————-
100 Po100(RU) - Te1/5/4(P) Te1/6/4(P)
200 Po200(RU) - Te2/5/4(P) Te2/6/4(P)

اگر کنسول را به شاسی دوم متصل کنید:

6500A-sdby>
Standby console disabled

Multi-Chassis EtherChannel

یک VSS میتواند تا 512 عدد EtherChannel را پیاده سازی کند. از آنجا که دو channel برای ایجاد VSL (هر کدام روی یک شاسی) استفاده میشود این تعداد در عمل به 510 کانال کاهش میبابد که البته بیش از نیاز شبکه های امروزی است. همانطور که اشاره شد MEC به EtherChannel ی گفته میشود که بین سوییچ مجازی و یک دستگاه دیگر نظیر سوییچ Access ایجاد میشود. از آنجا که سوییچ مجازی متشکل از دو سوییچ است در واقع این Channel بصورت فیزیکی بین سه دستگاه ایجاد شده و منجر به Load Balancing و Failover در ارتباط با سوییچ مچازی میگردد.

در شکل زیر سوییچ 3750X را به VSS (از طریق پورت فیبر) متصل کردیم. پس این سوییچ میتواند با پهنای باند پرسرعت به هر دو 6500 بصورت L2 یا L3 بواسطه یک Port Channelتنظیم و متصل گردد.

Virtual Switching System چیست

برای تنظیم MEC از نمونه زیر استفاده کنید:

Access switch:

interface GigabitEthernet1/1/1
channel-group 10 mode on
!
interface GigabitEthernet1/1/2
channel-group 10 mode on

Core switch:

interface Port-channel10
switchport
!
interface GigabitEthernet1/3/17
switchport
channel-group 10 mode on
!
interface GigabitEthernet2/3/17
switchport
channel-group 10 mode on

Verify:

6500A#sh etherchannel summary
Number of channel-groups in use: 3
Number of aggregators: 3

Group Port-channel Protocol Ports
——+————-+———–+————————————–
10 Po10(SU) - Gi1/3/17(P) Gi2/3/17(P)
100 Po100(RU) - Te1/5/4(P) Te1/6/4(P)
200 Po200(RU) - Te2/5/4(P) Te2/6/4(P)

Switch12#sh etherchannel summary
Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
——+————-+———–+————————————–
10 Po10(SU) - Gi1/1/1(P) Gi1/1/2(P)

به نقل از سیسکو به زبان پارسی

لینک کوتاه پست
مطالب مرتبط با پست جاری
  • نکات مهم
    1- لطفا نظر خود را با زبان فارسی بیان کنید
    2- رایتم نظرات اسپم و تبلیغی شما را تایید نمی کند
    3- لطفا نظرات شما بدون ابهام و واضح باشد
  • نام
    ایمیل (منتشر نمی‌شود) (لازم)
    وبسایت
    :):(;):D;)):X:?:P:*=((:O@};-:B/:):S
    نظر خصوصی
    مشخصات شما ذخیره شود ؟[حذف مشخصات] [شکلک ها]
    کد امنیتی
به کانال تلگرام سایت ما بپیوندید